RootsMagic Magic Guide

Importing Family Tree Maker into Older Versions of
RootsMagic

This quide is only needed if you have older versions of RootsMagic. RootsMagic 7.1.0.0
and later can directly import Family Tree Maker files. (See Magic Guide “Family Tree Maker
Direct Import in RootsMagic”)

This Magic Guide covers:

A. Importing FTM 2006 and Earlier Directly into RootsMagic B8 RootsMagic 7

B. Importing FTM 2008 or Later into RootsMagic File | Edit Lists Add View Se
e Preparing to Move your Family Tree Maker Database o Hew. Chl:M
e Importing your GEDCOM into RootsMagic ¥ Qpen.. k9

C. Media Open Recent »

Search for Files...

A. Importing FTM 2006 and Earlier Directly into

- Rename...
RootsMagic "
Delete...
1. Open RootsMagic. If a file is open, go to the File menu and Sopy.
select Close. Once the screen is blank, go to the File menu and Database toof:
select Import. \ Compare files...
v Import lists...
2. On the |mp0rt @ ,:3_ Print a Report... Ctrl+P
File window, select 0 Import File from Another Program Print Setup...
Family Tree Maker
y . Which genealogy program does the file come from? H Import.
(2006 and earlier). B Eeon.
. « (O RootsMagic (version 1-3) 7 FamilySearch Central...
3. Click “Search for e : =
. . (O Family Origins (version 4 and later) Save to Dropbox for Apps...
files” if you do not (® Family Tree Maker (2006 and earlier) I8 Backup
know where the file o
. IS Restore...
is stored. If you (O PAF (Personal Ancestral File) —
ropertes...
know where your (O TMG (The Master Genealogist) : S
file is, click (O GEDCOM (Other programs) m Exit
‘I know where the , —
file is.” () See details Search for files | | | know where the file is I\ Cancel
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4. Name your file.
|

%) New File - O
@

Create a new RootsMagic file
Create a new RootsiMagic file to hold the imported data

New file name IMain[

| File location... C:\Users%Cina\Documents\Main.rmgc

Opticns for this file

[[]Display surnames uppercase

Date format
10Jan 1959 v [C]LDS support

FamilyS h Family Ti rt
Number to display after name [ FamilySearch Family Tree suppo
None < Enable WebHints

[[]Match to FamilySearch when hints found

5. Verify that
the file location
is correct. If
not, click the
“File location”
button to save
someplace
else.

6. Choose
where you want
the file to be
saved. This
example shows

that the file will
be saved to Documents>ROOTSMAGIC>Files.

(&) select Folder X
& v & |1 > ThisPC >f Documents > ROOTSMAGIC | «[®] | search ROOTSMAGIC 0
Organize v New folder // == 0

Outlook Files 2 Name// 2 Date modified Type Size
/
PAF /Backup File folder
Personal Historian o File folder
Recipes // File folder
Relief Society / "TFOR / File folder
ROOTSMAGIC I GEDCOM File folder
- Index / File folder
Backup
Medi/! File folder
e Repbrts File folder
Files /
FOR /
/
GEDCOM /
Index //
Media /
Reports //
The Master Genealogist v/
I Folder: | Files I
/ [ Select Folder Cancel

/

7. Click the “Select Folder” button to save the selection and return to the New File

window.
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8. The File location reflects the desired placement for the file.

9. Select the file options you want applied to this file.

i éi New File )

Create a new RootsMagic file to

Create a new RootsMagic file

hold the imported data

New file name lMain

Number te display after nam

File location... = C:\Users\Cina\Documents\ROOTSMAGIC\Files\Main.rmgc
10. Click OK
Options for this file ' to import the
Dateforoat [[] Display surnames uppercase file
10 Jan 1958 v [JLDS support )

/

[C]FamilySearch Family Tree support

Record number

Reference number (REFN)
FamilySearch ID

Enable WebHints
[ Match te FamilySearch when hints found

11. If you created custom events (facts) in your Family Tree Maker database,
RootsMagic will need to know where to put that data. The “Import Family Tree Maker

file” window will
open. By default,
the custom fact’'s
data will be placed
in the “Desc”

<

X

= O

Eﬂ Import Family Tree Maker file >
I ———

Where should RootsMagic save the "comments"” text?

FTM facts only have a single field which holds either a place or other descriptive text. Click the desired
column for each fact type to tell RootsMagic whether to save that text in the place field, description
field, or note for each imported fact type.

(Description) field.
You can change the
placement to the
“Place” or “Note”

Fact / Event Place | Desc |Notes #
Individual Note
Phone number
Email

Interred

History

field, by clicking in
the column.

12. Click “Continue”
to finalize your
import.

Military
Tattoo
MyCustNum

| Reference

LEE KK

Death of Spouse
Death of Child (11

b4k

v

) i
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13. Your imported file will open.

[ RootsMagic 7 - [C:\Users\Cina\Documents\ROOTSMAGIC\Files\Main.rmgc]
@ File Edit Lists Add View Search Reports Tools |[nternet Window Help

D2 & &S@RL+OPR-B-B-2-15-@ith % E-

»E= James SMITH-1
Spouses: 2 ¥ |b: 1906 in Salem, Story, lowa, United States
Parents: 1 ¥ \m: 2 Jun 1928 (age 22)
d: 8 Sep 1985 in Ames, Story, lowa, U.S.A. (age 79)
2 2 N & B8 Pedigree Family Descendants People WebSearch Timeline
Index 9
5 6

| Options _|Duke SMITH-167 ’
Name Born A -
NORMAN, Edvart Jentoft ... 1865 _ |Howard SMITH-250 ’
OBRAY (AUBRAY, AUBREY, ... 9 Jun 1861-6 Apr 1936 _
OBREY, Thomas Kay | {Myrna DOE-168 ’
ODCROFT, Dorthea 1647 s
OLDHAM, James Henry 1848 Howie SMITH-248 ’
POND, Elmira 1811 | [27 Mar 1886-9 Feb 1938
POND, Thaddeus 1770  [Leni DAVIS-206 |
QUIGLEY, Andrew 1831 28 Oct 1832-18 Mar 1899
ROBERTS, Deborah Lyn - -

Phebe Sophia DAVIS-214
ROBINSON, Oliver Lee 1833 i

22 Dec 1861-1 Mar 1891_

SANFORD, Margaret Elmira.. 1839
SHAW, Elizabeth =
SMITH, Burton Sylvester 1890

; ‘
SMITH, Charles TLE WP James SMITH-1
1906-8 Sep 1985

SMITH, Charles Daniel 1866

Eliza BARNUM-211 a0
15 Oct 1837-11 Feb 1911

B. Importing FTM 2008 or Later into RootsMagic

B Master - Family Tree Maker 2012

Plan \’ﬁ’; \ People &F] Pl

e Preparing to Move your Family Tree Maker Database Bl0ecit view Person [ook |

1. Open your Family Tree Maker with the genealogy file you want
to move into RootsMagic.

2. Click on the Tools menu and choose “Compact file”. Check the

options to make a backup and “preform extended analysis” if Iﬂ B,
available. Backup...
Restore...
3. Click on the File menu and choose Export. Privatize File
Go Offline
Exit Alt+F4
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4. Select “En}ire file”.

Export
Individgafs to export
(@ Entire file (O Selected individuals

Individuals included:

Qutput format:

Family Tree Maker

Family Tree Maker
Family Tree Maker 2011
Family Tree Maker 2010

Include media files
Include private media
Include tasks
Include charts, reports, and books

[] Include only items linked to selected
individuals

Cancel Help

5. Under the “Output

L»GEDCOM 5.5.

6. Uncheck “Privatize
living people” so all

Check the remaining

notes and media for

everyone.

I

format” heading, select

individuals are included.

boxes to include facts,

Export

7. Click OK to save these
settings and continue.

Individuals to export
@ Entire file

Individuals included:

(O Selected individuals

Output format
GEDCOM

l [] Privatize living people I

Include private facts
Include private notes
Include media files

Include private media

Help

8. Click the dropdown menu for “Destination” and select
“FTM 2012”. The “Character set:” option will change to

UTF-8.

9. Click OK

Export

Destination:

Character set:

to GEDCOM

FTM2012

Other
FTM 16
FTM 2008
FTM 2003
FTM 2010
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10. Name your file and choose where you want the file to be saved. In this example it is being
saved to the Desktop so that it can be easily found. Then click Save.

Export to...

Organize v New folder

¢& OneDrive

[ This PC

[ Desktop I
3 Documents

& Downloads

J) Music

&= Pictures

B videos

s 0S(C)

wa HP_RECOVERY (D:)
s My Passport (F:)

¥ Network

<« v 4 B> ThisPC > Desktop

Name Date modified Type Size

,‘v Downloads
4| Google Drive

Shortcut 2KB

Shortcut 2KB

Save as type:  GEDCOM (*.ged)

4 Hide Folders

n Success! Export completed.

Export Status X

11. Your GEDCOM file will be completed.

12. Click OK to close the dialog window.

13. Close Family Tree Maker.

14 Now you are ready to import your GEDCOM file into RootsMagic.
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e Importing your GEDCOM into
RootsMagic

L2 RootsMagic7

[ Eile | Edit Lists Add View

Search Reports Tools Intern

@O OB

™ ﬁm Ctrl+N
. E‘J Open... Ctrl+O
1. Open RootsMagic. 2
Open Recent »
2. If afile is already opened click “File” and | Seatcliforbles..
choose “Close”. > | Close I
Rename...
3. If no database is currently open, Dielite:.
importing a GEDCOM will automatically ~
. Copy...
create a new RootsMagic database for
Database tools...
you.
Compare files...
4. Click on “File” menu and choose Import lists...
“Import”.  =— & Print a Report... Ctrl+P
. ) \ Print Setup...
5. On the “Import File” window, select the ,
option, “GEDCOM (Other programs)”. o Import..
w Export...
:'iéi‘ FamilySearch Central...
i T

@ Import File from Another Program

Which genealogy program does the file come from?

©@ RootsMagic fversion1-3)
() Family Origi
) Family Tree Maker (2006 and earlier)
© Legacy

() PAF (Persogiel Ancestral File)

() TMG (The Master Genealogist)

) GEDCOM (Other programs)

(version 4 and later)

L

@ See details

» Search for files J [ ~Tknow where the file is )

6. If you do not know
where the file is, click
“Search for files”.

RootsMagic will look for all
of your .ged files. Choose
the file you want from the
list.

If you know where the file
is stored on your
computer, click “I know
where the file is”.
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7. If you clicked, “I know where the file is”, this window will open.

8. Maneuver to where the file is stored. The file name will end with .ged.

In this & open X
example’ the € v /4 Bl > ThisPC > Desktop v d Search Desktop Pl
f||e |S on the Organize v New folder = v [ o
deS ktop You b ik dccess Name - Date medified Type Si
W||| need to . &2 Dropbox .‘ (D;ownllogd.s z:cicuz
. 2. Google Drive ortcu
find the folder . & OneDrive Master.ged GEDCOM file
where your file [+ @ hispc
is stored. | M Oeskiop
; @ TR Select a file
C||Ck i ‘ Downlaads to preview.
P o > D Music
Des ktop or » [&=] Pictures
the folder
where your file
. . HP_RECOVERY
is stored. Files - :
) - My Passport (F:)
in that folder v < >
will appear in / File name: ~| |GEDcoMm (ged) v
the right panel S

9. Click on the file.

10. Click “Open” to open the file.

11. Enter the file name you want to give this file. The name can match the GEDCOM file name
or be completely different. Do NOT give it the same name as any other RootsMagic

database on your|computer.

L0 New File &

=<

Create a new RootsMagic file
Create a new RootsMgic file to hold the imported data

New file name

C:\Users\Cina\Documents\ROOTSMAGICY

—

Options for this file

[ Display surnames uppercase
[]LDS support

Date format
110 Jan 1959

’)

Number to display after name

<

["] FamilySearch Family Tree support
[¥] Enable WebHints

None v

Record number

\_ [ Match to FamilySearch when hints found

Reference number (REFN) Ok

[ Cancel ]

FamilySearch ID
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12. Under “Options for this file” you can select the “Date format”, “Number to display after
name”, and several other options. These options can be modified after the file is created by
going to Tools > File Options.

13. Click “OK” when done.

GEDCOM Import > 14. You can leave this
window “as is” or change
GEDCOM Import the option and fill in the

blanks as desired.

Add a new source to tell where information in this GEDCOM came from?
[NO - Do not add an additional source to imported data v]

Name of person you received this GEDCOM file from 15. C_IiCk "OK" to finis_h
creating a RootsMagic
database from the
GEDCOM file.

Address (or email address) of person you received the file from

16. Your file is now ready to
oK [ ool 1 use in RootsMagic.

RootsMagic 7 - [C:\Users\Cina\Documents\ROOTSMAGIC\Files\New Master.rmgc]
@ File Edit Lists Add View Search Reports Tocols |Internet Window Help

N2 & &SHRLTOR-B-8-2-1- Gt ¢ E

Francis Joseph Ley

Spouses: 1 ¥ |b: 19 Mar 1817 in Wollschiller, Alsace, Germany
| Parents: 1 ¥ Im: 12 Aug 1841 in Mccutchenville, Seneca, Ohio (age 24)
d: 12 Oct 1902 in Delphos, Allen, Ohio (age 85)
2 2 N & B8 Pedigree Family Descendants People WebSearch Timeline
Index Father: () 1]
- 5 Francis Joseph Ley .
Sptoie b: 19 Mar 1817, Wollschiller, Alsace, Germany
Name Born | A m: 12 Aug 1841, Mccutchenville, Seneca, Ohio
Berry, James F 1857 d: 12 Oct 1902, Delphos, Allen, Ohio :
Berry, Mary 1898 Mother: 01
Berton, Jean Louis 1785 Mary Ann-Burta
B WA 1821 b: 20 Aug 1821, Somerset, Perry, Ohio
QT VAR AN d: 9 Jun 1872, Marion Township, Allen, Ohio, United States
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C. Media

In order for your media links to work in RootsMagic, the media must be on your computer and
not online. If any of your media links start with trees.ancestry.com or end with .htm or .html,
those media items are on the internet and not your computer. They have to be downloaded to
your computer if you want to see them from within RootsMagic. If you have FTM 2012 or 2014,
resync your FTM file to the online tree to downloaded the media to your computer, then re-
import your FTM file into RootsMagic.

RootsMagic links media from wherever you have it stored on your computer. This allows you to
organize your media files any way you like. RootsMagic does not create a special media folder
or copy media from one place to another.

If you have media in a Family Tree Maker folder, you can keep it there OR move the folder to
someplace else. You can even rename the file if desired. This process will break the current
media links, therefore to fix them, do the following:

G4 RoctsMagic 7 - [EAWORK.rmgc] 1. Go to the Lists menu in RootsMagic and select
Lo File Edit View Search Reports Media Gallery.
@ Lé& J Source List... ,

S E ALl | 2. If you see boxes with red Xs, click the Tools
Spouses: 1 Media gallery.. I] button and choose "Fix broken media links".
Parents: 1 Address List...

LDA'S: BEFS Repository List...
2 & | :‘I < Correspondence List...

Index (:‘* Place List...

A RootsMagic
Media Gallery

o Add new media || [ View /Edit || %% Properties | 3¢ Removemedia | < Print

/O]
A
£ Rachael Sabina Robison
*® *® *®
084489~1 (2)Rob... [Rollins & Hattie Sh..

Caption: _
File: C:\Users\Debbie\Documents\Family Tree Maker\Minor-Vogel-Peterson-
* * * o Martin-Brewer-Nielsen Family Tree Media\.jpg

10 - Copy 12887265_12424... § 16965136_11656... § 16987197_11658...

x x x x

1800 United State...|1810 United State... ] 1820 United State... 1820 United State...

List Sorted: File name ]

OK Cancel
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[ Fix Broken Media Links

Fix Broken Media Links

Where do you want to search for th

<All drives>
<All drives>

<A folder>
C:\

I

—

3. A new window will open. The
default is to look for the media on <All
L. drives>. If you don't know where the
media is stored, or if it is stored in
different areas on your computer,
keep the default option of <All

drives>.
Gl

4. If you wish to focus your search to a
specific folder or sub-folders, change

CHIonmo
P S en o asy

the option from <All drives> to <A
folder>.

\

5. Another window will open so that you can maneuver to the correct folder.

@ Select Folder X
« v 4 &> ThisPC > Pictures v|®| | Search Pictures p . . .
S .. @ | 6 Select/highlight the folder and click
& Quotes-Talks-Dre » ~| the "Select folder" button.
£R RootsMagic-Shar 3
@ RS-Dropbox * ~
@ Talks_QDthes ~ =
@ Work-Dropbox 0_Templ1 1_PhotoFamilyHif Camera Roll Chicago .
i soy | 7. Click OK to start the search.
/ g,
[ This PC ’ Sy |
= / i & ]
[ Desktop / ,-‘ :v‘y%
j Documents 8 / Exs x”
‘ Downloads Chihuly 2014 / clip art Flowers
D Music /I
&= Pictures E CT/
B Videos ./ A<
i 0S(C) S L
Folder: l 1_PhotoFamilyHistory
~ ~ Select Folder Cancel
~
~o -
~o (&5 Fix Broken Media Links — (m} X
~
~
\\\Fix Broken Media Links
=S
8. RootsMagic will look for your media. Whereta.you want to search for the media?
. L . folder> M
If only one version of the file is found, it SRR I
. . . Search this and all sub-folders
will be linked to ROOtSMag|C |”,::wsers\canavﬂictures\1_PhotoFamilyHistory &7 [;:]|
automatically.
Cancel
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9. If more than one version of your file is found, you will be given the opportunity to choose
which folder you want to link to.

G Select Folder - 0 X 1_10. The name of the file
IC} Select Folder appears, followed by the
A file by this name was found in more than one folder. Please sef ile you wish to use. path that was Originally

used to link to the image.
Below that are folders
where the image is currently
located. Select the folder
you want to link to.

Filename: Uncle Neely-cropped.jpg
Original Folder: C:\Users\Cina\Pictures\1_PhotoFamilyHistory\PAF Photos\

Folder
C:\Users\Cina\Pictures\Pictures\ 015 11:59:52 AM
C:\Users\Cina\Pictures\1_PhotoFamilyHistory\Relatives_Ancest... 03KB 5/29/2014 2:51:32 PM
C:\Users\Cina\Pictures\Mueller Family Media\ 103KB 10/9/2012 9:06:28 AM

Size Date

11. Click “Use this Folder”.

< >

Use this same folder for similar files

| UsethisFolder | Skip Skip All
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